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Figure 1. SOMPLC-F28M35

An IMPORTANT NOTICE at the end of this TI reference design addresses authorized use, intellectual property matters and other
important disclaimers and information.

All trademarks are the property of their respective owners.
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1 SOMPLC Description
The SOMPLC-F28M35 is a single-board system on module (SoM) for PLC in the FCC and ARIB
frequency bands. This single hardware design supports several popular PLC industry standards including
G3 and IEEE-1901.2. TI's certified PLC software is available with the SOMPLC-F28M35. Engineers can
take the SoM design and integrate it into their overall system board or keep the design as an add-on
board to their application. The only additional hardware required is the AC mains line coupling circuitry.
The included hardware schematics and Gerber files simplify the task for engineers to add PLC to their end
system. OEMs will benefit from having the ability to rapidly evaluate and prototype Power Line
Communications technology in their application.

2 Boot Modes

2.1 SW2 Positions
Boot mode can be selected using the switch SW2 and boot configuration resistor R85 - R92. The available
settings are described below.

Boot (Default Setting)
Position 1: OFF
Position 2: OFF

Wait In RESET
Position 1: ON
Position 2: OFF

Table 1. Boot Strap Resistors

BOOT Mode GPIO 34 GPIO 35 GPIO 47 GPIO 43
Configurations (R85=1,R89=0) (R86=1,R90=0) (R87=1,R91=0) (R88=1,R92=0)
Boot from master subsystem X 0 1 0
serial peripherals
UART0/SSI0/I2C0)
Boot to master subsystem X 1 1 1
flash memory
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3 UART SCI Communication
To communicate with the SCI, the following requirements must be met:
• Baud rate = 57600
• Message data bits = 8
• Stop bits = One
• Parity = None
• Handshake = None
• RTS enable = True

NOTE: There is no RS232 driver on the SOMPLC. Communications to the RS232 devices must be
considered external to this design.

4 PLC SoM Module I/O Definition
The following section details the I/Os and interfaces supported on this module.

At a minimum the required connections listed Table 2 must be used for the SoM to function properly. The
additional optional connections can be used if desired.

Table 2. SoM Connections

Required Connections Optional Connections
28x SCI (UART) ADC
Line GPIOs
15V CAN
3V3 SSI
GND I2C

M3 UART
Zero Cross
Analog GND

All signals listed in Table 2 are routed to a 34-pin connector used to interface a “motherboard”. This
connector serves as both an electrical and mechanical connection. Table 3 lists the pinout of the 34-pin
connector.

Table 3. 34-Pin Connector Pinout

Pin No. Name I/O Electrical Description
1 L1 I/O 0 V (GND) Neutral (analog ground), connected to the

PL coupler
2 L2 I/O 0 V(±6V Peak) Analog PLC signal, connected to the PL

coupler
3 NC NC – Unused
4 NC NC – Unused
5 GND – – Ground
6 GND – – Ground
7 V15 – +15 V to +18 V Power supply pin (+15 V nom). Peak

current 400 mA in transmit mode (average
100 mA).

8 3V3 – +3.14 V to 3.46 V CPU and Logic Digital Power pin (+3.3 V).
Max current 1000 mA.
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Table 3. 34-Pin Connector Pinout (continued)
9 EN/GPIO I-I/O -0.3 V to VCC + 0.3 V System Enable (logical level, active high).

Controls the power up and power down
functions of the module. When Low, the
module goes to power-down mode. This
feature is not yet implemented in software
or GPIO PB5_GPIO13.

10 ZC I -0.3 V to VCC + 0.3 V Buffered ZC input. This input must be
isolated from the power line and buffered
before entering this pin.

11 External PLC Host RX I -0.3 V to VCC + 0.3 V 28x asynchronous serial host-transmit
(input)

12 External PLC Host TX O -0.3 V to VCC + 0.3 V 28x asynchronous serial host-receive
(output)

13 Phase B/GPIO I-I/O -0.3 V to VCC + 0.3 V Phase B Enable signal (for 3-phase
selection) or PA5_GPIO5

14 Phase C/GPIO I/O -0.3 V to VCC + 0.3 V Phase C Enable signal (for 3-phase
selection) or PB2_GPIO10

15 SDAA I/O -0.3 V to VCC + 0.3 V I2C data pin
16 SCLA I -0.3 V to VCC + 0.3 V I2C clock pin
17 ADC2-A0 I -0.3 V to VCC + 0.3 V Unused ADC input.
18 AGND – – Analog ground
19 GPIO I/O -0.3 V to VCC + 0.3 V Unused multipurpose pin, PA1_GPIO1
20 GND – – Ground
21 GPIO I/O -0.3 V to VCC + 0.3 V Unused multipurpose pin, PA7_GPIO7
22 GND – – Ground
23 CAN RX/GPIO I-I/O -0.3 V to VCC + 0.3 V CAN RX interface or GPIO PE6_GPIO30
24 CAN TX/GPIO O-I/O -0.3 V to VCC + 0.3 V CAN TX interface or GPIO PE7_GPIO31
25 M3 SSI CLK/GPIO I/O -0.3 V to VCC + 0.3 V M3 SSI Clock (SPI clock) or GPIO

PD2_GPIO18
26 M3 SSI Frame/ GPIO I/O -0.3 V to VCC + 0.3 V M3 SSI Frame(SPI Enable) or GPIO

PD3_GPIO19
27 M3 SSI TX /GPIO O-I/O -0.3 V to VCC + 0.3 V M3 SSI TX (SPI Slave in, Master out) or

GPIO PD0_GPIO16
28 M3 SSI RX/GPIO I-I/O -0.3 V to VCC + 0.3 V M3 SSI RX (SPI Master in, Slave out) or

GPIO PD1_GPIO17
29 System RESET I -0.3 V to VCC + 0.3 V Reset of PLC-SOM (active Low)
30 GPIO I/O -0.3 V to VCC + 0.3 V Unused multipurpose pin PA4_GPIO04
31 NC NC – Unused
32 NC NC – Unused
33 RX-B/GPIO I-I/O -0.3 V to VCC + 0.3 V M3 UART RX or GPIO PB7_GPIO15
34 TX-B/GPIO O-I/O -0.3 V to VCC + 0.3 V M3 UART TX or GPIO PB6_GPIO14

5 Mechanical Specifications
The single 34-pin dual-row header used to interface the SOMPLC is specified as follows.

The SOMPLC contains a male 0.05-mil header (2 x 17) placed on the back of the PCB.
• This connector is keyed so that the module cannot be placed backward.
• An example part that will fit this design is a Sullins Connector Solutions, part number: SBH31-NBPB-

D17-SP-BK, Digikey part number: S9108-ND

A motherboard used to connect to the SOMPLC must use a compatible (2 x 17) connector.
• This connector is keyed and should follow the appropriate orientation as the male connector.
• An example part that will fit this design is a Sullins Connector Solutions, part number: SFH31-NPPB-

D17-SP-BK, Digikey part number: S9117-ND
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Figure 2 shows the top view of the female connector, which would be placed on the host board.

Figure 2. 34-Pin Female Connector (Top View)

6 PLC SoM Programming
To program a SoM that has never been programmed, the user must perform the following steps:

6.1 Prepare for Programming
1. Install the desired Texas Instruments PLC development package from www.ti.com/plc.
2. Set switch SW2 to FLASH Boot Mode as described below (see Figure 3).

FLASH Boot Mode (Default Setting)
Position 1: OFF

Position 2: OFF

Figure 3.

3. Connect a Texas Instruments XDS510 or XDS100V2 class emulator to the SoM using the 14-Pin
JTAG header on the SOM.

6.2 Program the Concerto SoM with TI Emulator and Code Composer
1. Create the Concerto Target Configuration.

(a) In CCS, go to View > Target Configuration.
(b) Click the New icon to create a New target configuration.
(c) If you are using the XDS510 emulator, assign a name to your configuration (for example,
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ConcertoXDS510.ccxml).
(d) Configure the target:

(i) Connection Menu, find the appropriate XDS510 Emulator
(ii) Device (check box) F28M35H52C1

(e) If you are using the XDS100V2 emulator, assign a name to your configuration (for example,
ConcertoXDS100V2.ccxml).

(f) Configure the target:
(i) From the Connection menu, select the Texas Instruments XDS100v2 USB Emulator
(ii) Select the F28M35H52C1 device check box.

NOTE: If you do not see F28M35H52C1, then the CCS you have installed probably does not
have the ARM tools. These are required for Concerto, so we recommend using CCS
version 5.1.1 or greater.

(g) Save configuration

Figure 4. Save Configuration

2. Go to View -> Target Configurations
3. Click Launch Selected Configuration.
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Figure 5. Launch Configuration

4. Select Tools -> On-Chip Flash.

Figure 6. On-Chip Flash

5. Under Erase Settings, select the Necessary Section Only (for Program Load) button.
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Figure 7. Erase Settings

6. Select (right-click, connect) the Cortex_M3_0 device and Load the flash_m3.out Cortex_M3_0 part.
Wait for it to finish, then disconnect from the Cortex_M3_0 part.

Figure 8. Load flash_m3.out

7. Select (right-click, connect) the C28xx_0 device.

Figure 9. Select the C28xx_0 Device
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8. Load the g3_plc_F28M35x.out, wait for it to complete.
9. Load DFU.out, wait for it to complete.
10. Load APPBOOT.out, wait for it to complete.
11. Disconnect from the C28xx_0 device.
12. Power cycle the SoM board.

7 Modify the Zero Configuration GUI Config File
After installing the Zero Configuration GUI, the user must change the default value of the serial port that is
used to communicate with the SoM. This default behavior is changed by modifying a file within the Zero
Configuration GUI utility. The following steps describe this process. (See Section 8.4, Step 4: Testing)
1. Browse to C;\Program Files\Texas Instruments\PLC Application Suite.
2. Open the file, PLC_Application_Suite.exe.config in a text editor.
3. Search for the following section in the file:

<setting name="DefaultSCIPort" serializeAs="String">

<value>SCI_B</value>

</setting>

4. Change the line <value>SCI_B</value> to <value>SCI_A</value>

8 Test Procedure
To test the SoM the operator needs the following items:
• A host computer running WindowsXP or Windows7 and two available USB ports
• Two SoM docking stations
• 15-V external power supply for each docking station
• Power line connector for each docking station
• USB cable for connecting to host PC for each docking station

– A single host PC can be shared between the two kits.
• Zero Configuration GUI

– Requires a modified .config file.

8.1 Step One: Set Up
1. Plug in the included SoM to each 34-pin SoM connector.
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Figure 10. The 34-Pin SoM Connector

2. Connect Neutral and Line (marked on the AC power cable) to the power grid connector P1 of each kit;
ensure the neutral and line connections are not shorted.

Figure 11. Neutral and Line Connections

3. Ensure the position of switches SW1 and SW2 are set to default setting, as shown in Figure 12 to
communicate to PC GUI via SCI-A.

Figure 12. Default Setting
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8.2 Step Two: Power Up
1. Connect the 15-V wall-mounted power supply to the AC receptacle of each kit.
2. Set switch SW3 of each kit to ON to power the boards

Figure 13. SW3 ON Position

8.3 Step 3: Connect to a PC
1. Plug in the micro-USB to the kit and connect the USB cable to the PC. Repeat this step for the second

kit.
Note: You may be asked to install USB-Serial drivers. If so, proceed to install the drivers, which can be
found in C:\Texas Instruments\G3DevelopmentEvalPackageVxxxx\XDS100 Drivers. It will be
necessary to reboot your PC after the drivers are installed, even if you are not asked by Windows® to
do so.

2. Verify the modems have been installed correctly by using the Device Manager (Start -> Control Panel -
> System -> Device Manager -> Ports)
Note: The four ports shown in Figure 14 are for twoboards.

Figure 14. Device Manager Shows Four Ports

8.4 Step 4: Testing
1. Install the Zero Configuration tool from C:\TexasInstruments\G3DevelopmentEvalPackageVxxxx\Tools,

and launch the tool. If you are using only one PC, it will be necessary to launch two instances of the
tool, one for each modem

2. When the Zero Configuration GUI opens, it uses the first available COM port to attach to a PLC.
Note: Ensure Diagnostic Port and Data Port are configured to SCI-A by clicking CTRL+A in the GUI
window.
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Figure 15. Ensure Proper Port Configuration

3. Connect each PLC kit to the power line and ensure the devices are connected on the same power line
phase.

WARNING
HIGH VOLTAGE! Use caution when connecting to the power grid to
avoid electric shock.
If there is concern about connecting to the power grid, a power
strip can be used to connect the two modems together. When
using a power strip, the power strip does not need to be plugged
into the power grid. Connect each PLC kit to the power line.
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Figure 16. Connect to the Power Line

4. Enter the desired text into the Message Window.
5. Press the Send Message button; the message will then be received by the other GUI.
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Figure 17. Sending and Receiving Messages Using the GUI

6. The File Transfer function, located in the bottom left-hand corner of the GUI, can be used to transfer
files.
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Figure 18. The File Transfer Function

(a) Click on the Browse button to display the standard Windows file browser to choose the file you wish
to transfer. You may choose only one file at a time may be chosen for the file transfer.

(b) After the file is chosen, click on the Transfer File button. The other PLC must also be controlled by
the Zero Configuration GUI.
When the transfer starts, the GUI will display a progress bar on both Zero Configuration GUIs. The
GUI in Figure 19 is the receiving Zero Configuration GUI and displays the path and filename where
the received file is being copied. The user is not allowed to change the directory path of the
received file.

15TIDU261–March 2014 SOMPLC-F28M35 Power Line Communication System on Module Design
GuideSubmit Documentation Feedback

Copyright © 2014, Texas Instruments Incorporated

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=TIDU261


Test Procedure www.ti.com

Figure 19. File Transfer Progress Bar

(c) When the file transfer completes the message box in Figure 20 displays on both Zero Configuration
GUIs.

Figure 20. File Transfer Complete

(d) If the file transfer fails, the sending GUI displays one of the message boxes shown in Figure 21.
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Figure 21. File Transfer Failed

The file transfer may be canceled by clicking on the ‘Cance button on either GUI.

9 Additional Information
FCC/IC Regulatory Compliance
FCC Part 15 Class A Compliant

Complies with IC: ICES-006; en conformité avec IC: NMB-006

10 Gerber Files
To download the Gerber files for each board, see the design files at http://www.ti.com/tool/tidm-somplc-
f28m35

11 Software Files
To download the software files for the reference design, see the design files at http://www.ti.com/tool/tidm-
somplc-f28m35
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