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User's Guide
SWAU058D–December 2008–Revised May 2018

Bluetooth® Logger and Link Quality Monitor (LQM) Tools

This user's guide describes the TI Bluetooth® debug tools used to capture and analyze the Bluetooth (BT)
firmware log messages and the protocol transactions from the CC256x dual-mode Bluetooth devices or
the WL18xx WiLink™8 connectivity devices. The BT Logger and the Link Quality Monitor(LQM) tools
provide visibility into the inner data and states of the BT controller as well as the information regarding the
protocol transactions with the remote devices.
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1 Requirements

1.1 Hardware Requirements
• Access to the BT_UART_DBG pin (for a WL18xx device) or the TX_DBG pin (for a CC256x device).
• A UART-to-USB converter to connect this pin to a PC.

The BT_UART_DBG/TX_DBG pin is a 1.8V UART TX pin that uses the baud rate of 921600. It must be
connected to a 1.8V level RX pin of the UART-to-USB converter and the UART-to-USB converter should
share the same ground as the BT controller.

NOTE: Multiple UART-to-USB adapters are available on the market, such as the FTDI Chip™ TTL-
232RG-VREG1V8-WE.

1.2 Software Requirements
• BT Logger and LQM applications. These applications are part of the WiLink Wireless Tools package

(download link).

NOTE: Once the Wireless tools are installed, the installation files can be found at the following path:

C:\Program Files (x86)\Texas Instruments\Wireless Tools

This directory is referred to as the Installation directory throughout this document.

• ILI and XML configuration files. The latest files can be downloaded from the following links:
– For WL18xx : WL18XX-BT-SP
– For CC2564C : CC256XC-BT-SP
– For CC256xB/CC2564MODN/CC2564MODA : CC256XB-BT-SP

2 Installation
The BT Logger and LQM are part of the TI wireless tools package release. When the wireless tools
package is installed, the Logger and LQM icons are created in the Texas Instrument\Wireless Tools folder
at Start→Programs and on the desktop (see Figure 1 and Figure 2).

Figure 1. Logger Icon

Figure 2. LQM Icon
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3 TI Logger
The TI BT Logger is used to capture the firmware log messages and protocol transactions from the BT
controller. The Logger has the following ports.
• BT Logger 1: All the firmware traces are captured under this port.
• HCI/LMP viewer 1: All the protocol transaction messages are captured under this port.

NOTE: In order to capture the complete logs, information from both of these ports must be captured
and saved.

3.1 Setting Up the TI BT Logger
Once the hardware is setup for the log capture and the required software is installed on the PC, the
following steps must be used to properly configure the BT Logger:
1. Double-click the Logger icon to start the Logger application. The main working window of the logger

should appear as shown in the below.

Figure 3. Logger Main Working Window
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2. From the menu bar of the main working window, click on the View->Settings... (Alt+F7).

Figure 4. Opening Logger Settings

The Logger Settings dialog box should appear.

Figure 5. Logger Settings

http://www.ti.com
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3. Select the BT Logger 1 under the Installed Ports list and click on the Setup... button.

Figure 6. Selecting BT Logger in Settings

4. In the Setup dialog box, select the COM port that is connected to the BT_UART_DBG / TX_DBG pin of
the TI BT controller.

Figure 7. Selecting COM Port

NOTE: Please ensure that the COM port number is less than 50. If not, change the COM port
number to a lower value from Control Panel on the PC.

5. Setup the COM port for the following settings and click OK.

Figure 8. BT Logger Serial Port Settings

http://www.ti.com
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6. Under the Mapping Files section of the Setup dialog box, click on Add File... button and select the
appropriate *.ili file for the BT controller as listed in the Software Requirements section above.

Figure 9. Adding the ILI File

NOTE: Make sure that only one *.ili file is selected.

7. Click OK to apply the changes to the Setup dialog box for the BT Logger 1 port. Next, configure the
HCI/LMP viewer port.

8. In the View->Settings... dialog box, select the HCI/LMP viewer 1 under the Installed Ports list and
click on Setup....

Figure 10. Selecting HCI/LMP Viewer in Settings

http://www.ti.com
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9. Setup the Serial Port Settings.

Figure 11. HCI/LMP Viewer Serial Port Settings

10. Select Add File... and select the appropriate *.xml file for the BT controller as listed in the Software
Requirements section above.

Figure 12. Adding the XML File

NOTE: Make sure that only one *.xml file is selected.

11. Click OK to apply the changes to the Setup dialog box for the HCI/LMP viewer port.
12. Make sure that both the BT Logger 1 and the HCI/LMP viewer 1 ports are checked and the COM port

is displayed next to both of them in the Logger Settings window.

http://www.ti.com
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Figure 13. Properly Configured Logger Settings

NOTE: If the COM port nuber is not displayed next to either the BT Logger 1 port or the HCI/LMP
viewer 1 port, uncheck and check each of the ports to load the COM port settings.

13. Click OK to apply changes and close the Logger settings.

http://www.ti.com
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3.2 Capturing the Logs
1. After both the BT Logger 1 and the HCI/LMP viewer 1 ports have been setup with the correct

configurations, click on the View->Show All Items option to disable any previously applied filters.

Figure 14. Getting the Logger Ready to Capture the Logs

2. Power up the Bluetooth® device and enable the BT controller. An initialization sequence will be
captured in the Logger windows as shown in Figure 15.

http://www.ti.com
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Figure 15. BT Controller Initialization Logs

3. When all the relevant traces (from both BT Logger 1 and HCI/LMP viewer 1 ports) are captured, use
the File->Save As... option to save the logs as a *.lgr file.

Figure 16. Saving the Logs

When capturing the logs for a long period of time (i.e. for several hours), it is best practice to use the
Auto Save and Clear feature of the Logger. Doing so prevents a single log file from getting too large
and it helps keep the logs organized for analysis later.

http://www.ti.com
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To Setup the Audo Save and Clear, click Edit->Auto Save and Clear... option to open the Save and
Clear window.

Figure 17. Selecting Auto Save and Clear

Click OK after setting up the parameters for Auto Save.

Figure 18. Configuring Auto Save and Clear

NOTE: When the log capture is complete, save the last instance by clicking File->Save As... option.

http://www.ti.com
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3.3 Analyzing the TI Logger Capture
The saved logger traces can be opened in a new window of the TI Logger by selecting File->Open. There
are several features in the TI Logger to help with analysis of the saved logs.

3.3.1 View Filter
The View Filter is used to see only the specified traces on the working window. This feature is useful when
limiting the log analysis to only certain type of traces and/or traces with a specific keywords.

To apply the View Filter, open the View->Settings window and click on the View Filter row of the
"Criteria" section.

Once the View Filter criteria is selected, enter the filter criteria in the Text box. For example, the macro "--"
can be used to only view all the HCI/LMP viewer traces.

Figure 19. View Filters

Click Apply to apply the View Filter.
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3.3.2 Highlight
The Highlight feature is used to highlight traces by color coding the traces that match the defined criteria.
To add a highlight filter, click on one of the Highlight Color criteria in the Logger Settings dialog box.

Once the Highlight Color row is selected, enter the criteria in the Text box and click Apply to highlight the
specified traces.

Figure 20. Logger Highlight Feature

http://www.ti.com
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3.3.3 Toggling Log Levels
Each log trace has a specific log level. Toggling the log levels can be used to quickly apply view filters to
the traces with the selected log levels.

Figure 21. Log Levels

3.3.4 Bookmarks and Comments
This feature is used to add Bookmark to a trace. It can also be used to (optionally) add a comment to the
bookmark.

To toggle bookmark on and off on a trace, select the trace and use Bookmarks/Comments->Toggle
Bookmark (Ctrl+F2). To add/edit comment on the bookmark, use the Bookmarks/Comments->Edit
Comment...(Enter).

Figure 22. Bookmarks and Comments

NOTE: The F2 or Shift+F2 shortcuts can be used to quickly jump to next or previous bookmark
respectively.

http://www.ti.com
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3.3.5 Find Function
The Edit->Find(Ctrl+F) option can be used to find a trace in the log file.

Figure 23. Find Dialog Box

3.3.6 Time Anchor
The Time Anchor is used to display the relative time of each of the traces in the log file with respect to the
anchored trace.

NOTE: Make sure that the View->Show Relative Time option is enabled before applying the time
anchor.

To anchor a trace, right click on the trace row and select Edit->Set Time Anchor.

Figure 24. Time Anchor
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4 Link Quality Monitor
The BT Link Quality Monitor (LQM) application monitors the Received Signal Strength Indication (RSSI)
and the Link Quality (averaged throughput) information during a connection in runtime.

4.1 Running the LQM
1. To start the LQM, click the Link Quality Monitor program icon (see Figure 25).

Figure 25. Starting the LQM

2. The LQM main window displays with the following panes (see Figure 26):
• RSSI pane
• Throughput pane
• Used-channel pane (BT and BLE)

Figure 26. LQM Main Window

http://www.ti.com
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3. To select the port:
a. From the toolbar, click the Port Connection box. A drop-down menu displays the available ports (see

Figure 27).
b. Select the desired port.

Figure 27. COM Port Selection

4.2 Using the LQM

4.2.1 Menu Bar
Table 1 describes the menu bar menus and submenus.

Table 1. Menu Bar

Menu Submenu Function

File

New Create a new LQM file
Open Open an existing LQM file
Save Save the active LQM file
Save as Save the active LQM file with a new name
Exit Exit the LQM application

View

Chart throughput results Display or hide chart throughput results
AFH Master Display or hide the AFH Master Piconet pane
BLE AFH master Display or hide the BLE AFH Master Piconet pane
BLE AFH Slave Display or hide the BLE AFH Slave Piconet pane
AFH Slave 1 Piconet Display or hide the AFH Slave 1 Piconet pane
AFH Slave 2 Piconet Display or hide the AFH Slave 2 Piconet pane
Standard toolbar Display or hide the standard toolbar
Status bar Display or hide the status bar
Customize Customize the keyboard and toolbar

Help LQM information and version number

http://www.ti.com
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4.2.2 Toolbar
Table 2 describes the toolbar options.

Table 2. Toolbar

Item Function
Create a new LQM file

Open an existing LQM file

Save the active LQM file with a new name

Port connection box

Select the port to configure the connection between the application and the device

4.2.3 Customize Dialog Box
To open the customize dialog box, click the View menu and select Customize. The Customize dialog box
with the following tabs (see Figure 28):
• Commands
• Toolbars
• Keyboard
• Menu
• Options

Use the Commands tab to drag and drop commands from the Customize dialog box to the menu or
toolbars (see Figure 28).

Figure 28. Customize Dialog Box With Commands Tab Selected

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SWAU058D


Link Quality Monitor www.ti.com

20 SWAU058D–December 2008–Revised May 2018
Submit Documentation Feedback

Copyright © 2008–2018, Texas Instruments Incorporated

Bluetooth® Logger and Link Quality Monitor (LQM) Tools

Use the Toolbars tab to enable and disable toolbars (see Figure 29).

Figure 29. Customize Dialog Box With Toolbars Tab Selected

Use the Keyboard tab to create a keyboard shortcut for each menu item (see Figure 30).

Figure 30. Customize Dialog Box With Keyboard Tab Selected

http://www.ti.com
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Use the Menu tab to customize menus, which includes animations and shadows (see Figure 31).

Figure 31. Customize Dialog Box With Menu Tab Selected

Use the Options tab to customize how menus are viewed (see Figure 32).

Figure 32. Customize Dialog Box With Options Tab Selected

http://www.ti.com
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4.2.4 LQM Active Window
The LQM active window displays the following kinds of data regarding the quality of the link (also
Figure 33):
• RSSI
• Used channels map

Figure 33. LQM Active Window

The LQM application supports up to seven BT handles and up to three piconets (one master and two
slaves).

http://www.ti.com
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4.2.4.1 RSSI Window
The RSSI window displays the RSSI measurements of up to seven handles. Each handle is represented
by a color. The scale of the window varies from 0[dbm] to –90[dbm]. The increase threshold is -65[dbm],
and the decrease threshold is –45[dbm].

Figure 34. Increase Transmitted Power

Each time the measured RSSI falls below the lower threshold, the device sends a request to the
transmitting device to increase the transmitted power to within the desired range (see Figure 34). In this
case, ↑ (up arrow symbol) indicates (in the same color of the specific handle) that transmitted power must
increase. When the transmitted power rises above the upper threshold, ↓ (down arrow symbol) indicates
that transmitted power must decrease.

The last throughput results sample is displayed near the related graph. Green text indicates enough
samples are present for statistics; red text indicates not enough samples are present for statistics.

4.2.4.2 Used-Channels Window
The Used-Channels window includes up to three channel maps and up to two piconets (a device can be a
master in one piconet and a slave in two other piconets).

Channels appear as decimal values from 0 to 78 (for example, channel 0 = 2402 MHz;
channel 1 = 2403 MHz).

The following colors can represent each channel:
• Light gray: the specific channel is not in use.
• Dark gray: the specific channel is recently removed.
• Blue: the specific channel is recently added.
• Black: the specific channel is in use.

http://www.ti.com
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Figure 35 shows the used-channels window.

Figure 35. Used-Channels Window
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Table 3 lists terms and abbreviations.

Table 3. Terms and Abbreviations
Term Description

BD_ADDR Bluetooth® device address

BER Bit error rate

BT Bluetooth®

HCI Host controller interface

Host/host PC A PC connected to the device through the serial port

LMP Link manager protocol

LQM Link quality monitor

PER Packet error rate

RF Radio frequency

RSSI Received signal strength indication

SW Software

VS Vendor-specific
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