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MSP430 Touch Pro Tool

This document describes the MSP430™ Touch Pro Tool and its features.
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1 Overview
The MSP430 Touch Pro Tool is a PC-based tool that can be used to verify capacitive touch button, slider,
and wheel designs. The tool receives and visualizes capacitive touch sensor data to help the user quickly
and easily evaluate, diagnose, and tune button, slider, and wheel designs.

Features of the Touch Pro Tool include:
• Receive real-time data from a target board up to ten signals
• Points connected or bar chart display styles for viewing real-time data waveforms
• User-configurable automatic ranging or manual ranging of the y-axis
• Data recording and recall
• Print waveforms
• User-selectable individual signal or multiple signal waveform display

MSP430, LaunchPad, BoosterPack, Code Composer Studio, MSP432 are trademarks of Texas Instruments.
OS X is a registered trademark of Apple Inc.
IAR Embedded Workbench is a registered trademark of IAR Systems.
Linux is a registered trademark of Linus Torvalds.
All other trademarks are the property of their respective owners.
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1.1 MSP430 Touch Pro Tool Revision

V1.00.00.00 Initial release
V1.10.00.00 Added Bar Chart, plot grid lines, plot signal aliases
V1.20.00.00 Modified to populate COM port list with all active ports
V1.30.00.00 Added support for OS X and Linux
V1.40.00.00 Added MSP430 demonstration project

2 Hardware and Software Requirements
The following items are required to run the Touch Pro Tool:
• PC with supported operating system

– Microsoft Windows 7, 32 bit or 64 bit
– Linux®, 32 bit or 64 bit (Ubuntu 12.04)
– OS X® v10.10.1+, 64 bit

• USB 1.1 compatible input
• Java Development Kit JDK1.5 or greater

2.1 Software Drivers
To use the LaunchPad on Linux and MacOs, some drivers mustbe updated.

For OS X
1. Follow the instructions at https://github.com/energia/Energia/wiki/Getting-Started.
2. The LaunchPad COM port will be listed as "/dev/tty.uart-*" in the Touch Pro GUI
3. If a port "already in use" message is displayed when trying to open the LaunchPad serial port, update

the permissions on the /var/lock file. Using the Apple Terminal, do the following:
sudo mkdir /var/lock
sudo chmod a+rw /var/lock

For Linux
1. Apply the LaunchPad cdc-acm kernel module fix from https://github.com/capnm/LaunchPad.
2. The LaunchPad registers as /dev/ttyACM*, but the RXTX serial port library only searches for /dev/ttyS*.

Create a symlink as in the following example:
(a) Before plugging in the LaunchPad, do a "ls /dev" to get the current list of /dev/ttyACM* entries.
(b) Plug in the LaunchPad and do another "ls /dev". The new "/dev/ttyACM*" entry is the LaunchPad.
(c) Create a link to a new unused /dev/ttyS* entry. Also update the permissions for the files. For

example:
ln –s /dev/ttyACM0 /dev/ttyS99
sudo chmod 0666 /dev/ttyS99
sudo chmod 0666 /dev/ttyACM0

(d) Open the /dev/ttyS99 port in the TouchPro GUI.
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2.2 Hardware
The MSP430 Touch Pro Tool can be demonstrated with the MSP430 LaunchPad™ Value Line
development kit (MSP-EXP430G2) together with the MSP430 Capacitive Touch BoosterPack™
(430BOOST-CAPTOUCH) daughterboard. Both are available for purchase from TI eStore:

LaunchPad: https://estore.ti.com/Product3.aspx?ProductId=2031
BoosterPack: https://estore.ti.com/430BOOST-SENSE1-Capacitive-Touch-BoosterPack-
P2361C42.aspx

The LaunchPad kit connects to a PC or laptop with a mini-USB cable, which is provided with the
LaunchPad (see Figure 1). Make sure that all of the jumpers are connected in their default configuration.

Figure 1. Hardware Connection

2.3 Demonstration Projects
The CCS and IAR source code for the demonstration projects is available in the installation package.
• The TouchProTool_Demo_Bit_Banging and TouchProTool_Demo_UART projects require Code

Composer Studio™ (CCS) version 5.3 or newer or IAR Embedded Workbench® (IAR) version 5.50 or
newer.

• The TouchProTool_Demo_UART_MSP432 project requires CCS version 6.1 or newer and IAR
Embedded Workbench® for ARM version 7.40.3 or newer.

The CCS and IAR projects directory contains files for three code examples.

The TouchProTool_Demo_Bit_Banging and TouchProTool_Demo_UART examples support the
MSP430G2553 microcontroller.
• The TouchProTool_Demo_Bit_Banging example supports the MSP430G2xx2 and MSP430G2xx3

Value Line MSP430 microcontrollers.
• The TouchProTool_Demo_UART example supports only MSP430G2xx3 Value Line MSP430

microcontrollers, because it requires a UART interface. The UART module should be wired according
to the instructions in the LaunchPad documentation.

The TouchProTool_Demo_UART_MSP432 example supports only MSP432™ microcontrollers.

To quickly evaluate the example projects, load the selected project into a CCS or IAR workspace. Then
connect a LaunchPad containing a compatible MSP controller to the host PC and download the firmware.

2.3.1 TouchProTool_Demo_UART_MSP432
This software is available in the Touch Pro GUI installation package and the MSP-EXP432P401R
Software Examples package, or it is more easily accessible through MSPWare. The software was
developed using CCS v6.1.0.00104 and IAR Embedded Workbench for ARM v7.40.3.8938 and can be
evaluated using either IDE.

The TouchProTool_Demo_UART_MSP432 example shows how to use the capacitive touch enabled I/Os
on the MSP432 MCUs with the Capacitive Touch Software (CTS) Library for MSP432 and the
430BOOST-SENSE1 BoosterPack.
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NOTE: The CTS Library provided for MSP432 is not meant to be a complete solution for capacitive
touch application development. Users wishing to develop complex capacitive touch
applications are encouraged to add on to or modify the existing CTS Library. For more
information on the CTS Library, see the Capacitive Touch Software Library for MSP432
Programmer’s Guide (SLAA673).

The example also provides a simple framework for tuning capacitive touch elements and sensors with the
Touch Pro GUI. The application code for the example is organized in multiple files. Table 1 summarizes
the main application files for the TouchProTool_Demo_UART_MSP432 example.

Table 1. TouchProTool_Demo_UART_MSP432 Files

Name Description
Main application file that initializes the system, calls CTS Library measurement functions, andTouchProTool_Demo_UART.c handles UART communication
Main application header containing definitions that control system initialization and applicationTouchProTool_Demo_UART.h mode

structure.c Source file used to configure capacitive touch elements and sensors
Header file containing declare capacitive touch elements and sensors and select capacitivestructure.h measurement method

The example can be built to measure the capacitive elements using all of the methods supported by the
MSP432 CTS Library. This includes hardware configurations for both the relaxation oscillator (RO) method
and the fast relaxation oscillator (fRO) method. The user can select which measurement mode is used by
changing which measurement method definition is uncommented in the structure.h file. Figure 2 shows
these definitions.

Figure 2. Capacitive Touch Measurement Method Definitions

The example can also be built to display either the change in capacitive element measurements or the
wheel touch position on a PC in the Touch Pro GUI. In addition, the example provides the option to
configure the system to have a master clock frequency of 1 MHz, 4 MHz, 8 MHz, 16 MHz, 24 MHz, or 48
MHz. These settings can be changed by modifying the preprocessor defines in the
TouchProTool_Demo_UART.h file (see Figure 3) and then rebuilding the project.
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Figure 3. User-Selectable Defines in TouchProTool_Demo_UART.h

Selecting a master clock frequency of 24 MHz or 48 MHz increases the frequency of the SMCLK in the
example, which affects the tuning of the capacitive elements and wheel sensor when using the fRO
measurement method. These settings demonstrate how the fRO method might be used to obtain better
sensitivity on capacitive touch structures at high measurement frequencies.

NOTE: For more information on the RO and fRO measurement methods, see the Capacitive Touch
Software Library for MSP432 Programmer’s Guide (SLAA673).
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3 Launch MSP430 Touch Pro Tool
The tool can be launched either by double clicking the touchpro.jar file in the install directory or by
selecting the tool in the Windows Start menu.

3.1 Main Window
When the Touch Pro Tool runs, the screen shown in Figure 4 is displayed.

Figure 4. Startup Screen

The main window (see Figure 4) is divided into four working zones:
• Main Menu: File, Edit, and Help
• Plot type selection and COM Communication: Select COM, Refresh COM, Pause/Un-pause buttons
• Display Area: Data display canvas
• Data Information: Signal, X-Value, Y-Value, and distance between two points
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3.2 Communication Setup
To select the COM port to which the LaunchPad is attached, click the Select COM button. In the
dropdown menu, select the appropriate COM port for the target device (see Figure 5). If the COM port is
not listed in the dropdown menu, click the Refresh COM button and then click Select COM again.

NOTE: More than one COM port may be listed in the COM window. To identify the appropriate COM
port for the Touch Pro Tool:

Windows: Run Windows Device Manager and select the COM port with the name MSP430
Application UART.

OS X: Select the port that matches "/dev/tty.uart-*".

Linux: Select the /dev/S* link that was created by following the instructions in Section 2.1.

Figure 5. COM Port

NOTE: If the COM port cannot be opened, a warning is shown.

3.2.1 COM Open
When the COM port is open, the Select COM and Refresh COM buttons are disabled, and the Pause/Un-
Pause button is enabled. A legend with checkboxes for selecting and deselecting signals is also
displayed.

The tool starts to display data curves when the COM port opens. The data flow can be paused and un-
paused without closing the COM port.

3.2.2 COM Closed
The COM port can be closed in two ways, either by selecting to open a history file or by exiting the tool.

Opening a history file (see Section 3.4.2.2) closes the COM port, enables the Select COM and Refresh
COM buttons, and disables the Pause/Un-Pause button.

With the COM port closed, the tool stops displaying data.

3.2.3 Pause/Un-Pause
The data flow can be paused for reviewing or un-paused by clicking the Pause/Un-Pause button.

3.2.4 Refresh COM
The Refresh COM button repopulates the COM dropdown box with the available COM ports. This allows
the user to plug in the USB cable while the Touch Pro Tool is open. The Refresh COM button is disabled
when a COM port is open, and it is enabled when the COM port is closed.
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3.3 Plot Types
The tool can display real-time data in two different plot formats, Oscilloscope or Bar Chart (see Figure 6).

Figure 6. Plot Type Selection

3.3.1 Oscilloscope View
The Oscilloscope view (see Figure 7) displays data for each signal as a continuous line on the plot.

Figure 7. Oscilloscope Plot View
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3.3.2 Bar Chart View
The Bar Chart view (see Figure 8) displays the most recent delta value for each signal as a bar. It also
provides the capability to set a manual threshold value for the displayed signal.

Figure 8. Bar Chart View

3.4 Data Types
In the Oscilloscope view, data can be viewed in real-time or historical mode. In Bar Chart view, only real-
time data can be viewed. In real-time mode, the tool displays data received from the COM port in real
time. In historical data mode, data that was previously saved to a CSV file is displayed (see
Section 3.4.2.2 for details).

3.4.1 Real-Time Data Display
The real-time data display, supported both in Oscilloscope and Bar Chart views, allows the user to view
data in real time. When COM port opens, all signals that are sent from the target board are displayed.
Data curves or bars can be observed and are displayed in real time in the display area (see Figure 7 and
Figure 8).

Click on the Pause/Un-Pause button (see Figure 9) to switch between stopping and starting of plotting
data. In the pause mode, data acquisition and data plotting are both stopped.

Figure 9. Pause/Un-Pause Button

3.4.2 Historical Data Display
Historical data can be recalled for viewing and analyzing from saved CSV type data files. Historical data
display is only supported in the Oscilloscope view.
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3.4.2.1 Save Data
To save data, the click File→Save or File→Save As. Data can be saved in real-time mode or in pause
mode. Data is saved in CSV formatted files.

3.4.2.2 Recall Data
To recall data, click File→Open and select the directory and the desired CSV data file. Historical data can
be recalled in either real-time mode or pause mode.

When a data file is opened, the tool automatically closes the COM port. The display area is cleared of all
existing data, and the historical data is displayed.

3.5 Signal Selection
The display of each received signal can be individually turned on or off. To turn on the display of a signal,
click the checkbox for that signal (see Figure 10). To turn off the display of a signal, clear the checkbox.
To select all signals, click Select All. To deselect all signals, click Deselect All. When the COM port is
opened, all signals sent by the target are automatically selected.

Figure 10. Signal Selection and Alias

3.6 Signal Alias
Each plot signal can be assigned a user-defined alias. This can be helpful to map signal numbers to
meaningful identifiers (see Figure 10).

3.7 X-Axis and Y-Axis Description
• Y-axis points are data values
• X-axis points are index counts

The y-axis can be labeled. Click Edit→Display Defaults→Axis Defaults and then enter the labels for Y Title
(see Figure 11).

3.7.1 Automatic Ranging and Manual Ranging
If the Y-axis data points vary widely, the values that are displayed can be restricted to a user-defined
range. Click Edit→Display Defaults→Axis Defaults and select Manual Ranging Y-Axis (see Figure 11).
Enter a minimum Y value and a maximum Y value. The changes to the Y-axis are seen the next time the
COM port opens.

The Y-Axis Boundary Settings can be set either during real-time data flow or when the data flow is
paused. The manual range's minimum and maximum values are stored when the tool closes. However,
Auto Ranging Y-Axis is the default setting that is used by the tool when it is opened. To apply the manual
range values to the Y-axis after restarting the tool, select Manual Ranging Y-Axis again.
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Figure 11. Display Chart Ranging (Axis Defaults Tab)

3.8 Display Chart Styles
Two styles of display charts are available: Points Connected and Bar Chart. To select the chart type, click
Edit→Display Defaults→Plot Defaults and select either Points Connected or Bar (see Figure 12).

Figure 12. Display Chart Styles (Plot Defaults Tab)
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3.9 Display Chart Grid Lines
To display the horizontal and vertical grid lines, click Edit→Display Defaults→Plot Defaults to open the
window shown in Figure 12.

3.10 Data Protocol Between MCU and Touch Pro Tool
For the Touch Pro Tool to display data, the user application must send data in a defined format. The data
frame definition of the UART protocol that the Touch Pro Tool expects from the target MCU is shown in
Figure 13.

Figure 13. Data Frame Definition

Frame Header: This is a fixed value. The value is always 0x55 and 0xAA.

Length: Indicates total number of bytes following the frame header bytes.
Length = 3 × Signal Numbers + 1.
For example, when there is only one signal of data to send, the length is:

3 × 1 + 1 = 4
When there are five signals of data to send, the length is:

3 × 5 + 1 = 16
Each signal number is multiplied by 3 to account for signal number, high order byte, and low order
byte. The 1 is then added to the length to account for the checksum byte

CH#: Valid signal numbers range from 0 to 9. That means a total of 10 signals can be observed by the
Touch Pro Tool.

High Byte: High 8-bit data of the signal data.

Low Byte: Low 8-bit data of the signal data.

CHKSUM: Low byte of the value derived from the sum of header bytes, frame length, signal number, and
data bytes. The tool ignores the data package if the checksum is wrong.

For example, if the data frame is the following:

Data Frame total = 55 + AA + 0A + 01 + 0 + 0A = 114
Checksum = 14

3.11 Waveform Operations
The following operations can be performed on the displayed waveforms:
• Zoom in and zoom out
• Show point values
• Show distance between points
• Print
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3.11.1 Zoom In and Zoom Out
Zoom in and zoom out are possible while data flow is paused or during data recall.

To zoom into a portion of a waveform, press and hold the left mouse button and draw a box from top to
bottom around the area of interest. To zoom out partially, press and hold the left mouse button and draw a
box from bottom to top around the area of interest. To zoom out fully, click the right mouse button.

3.11.2 Show Points Values
The X and Y points value is displayed in the Data Information zone of the tool. When the cursor is over a
point in the display, the corresponding signal number, X value, and Y value are listed in the boxes labeled
Signal, X, and Y, respectively. Figure 14 shows an example point value.

Figure 14. Show Points Values

3.11.3 Show Difference Between Points
To calculate the difference between two point values: select the first point, press and hold the right mouse
button, drag the line that appears to the second point, and release the button.

The boxes labeled DX and DY (see Figure 14) show the differences between the X and Y coordinates,
respectively, of the two points.

3.11.4 Print Waveforms
To print the waveforms that are shown in the display area of the tool, pause the data flow and then click
File→Print.

3.11.5 Clear Display
To clear the display of waveforms, click Edit→Clear. The display can be cleared in real time or when data
flow is paused.

3.12 Reset Axes
To reset the axes after zooming in, click Edit→Reset Axes. The display resets the x and y axes values to
the values prior to the zoom in.
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Revision History

Changes from April 30, 2015 to October 2, 2015 ............................................................................................................ Page

• Added tool revision V1.40.00.00 information in Section 1.1, MSP430 Touch Pro Tool Revision .............................. 2
• Updated the description in Section 2.3, Demonstration Projects ................................................................... 3
• Added Section 2.3.1, TouchProTool_Demo_UART_MSP432 ...................................................................... 3

NOTE: Page numbers for previous revisions may differ from page numbers in the current version.
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