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ABSTRACT
This application report describes a low-cost heart-rate monitor solution based on the MSP430G2
LaunchPad™ Development Kit, which supports the MSP430G2xx microcontrollers (MCUs). A
daughterboard amplifies and filters the electrocardiogram (EKG) signal before it is sent to the MCU for
sampling and processing. The heartbeat-per-minute data is sent to the PC by means of the back-channel
UART-over-USB available on the LaunchPad kit. Additionally, an eZ430 radio frequency (RF) target can
be connected to the six-pin header on the daughterboard to transmit data wirelessly using the SimpliciTI™
network protocol. The system can be powered by universal serial bus (USB) power, a CR2032 3-V coin
cell, or two AA or AAA batteries.

WARNING
The application presented here is for reference design purposes
only and is not intended for any life-saving or medical-monitoring
use.

Project collateral and source code discussed in this application report can be downloaded from
http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/EKG-Based-Heart-Rate-
Monitor/1_00_00_00/index_FDS.html.

Contents
1 Introduction ................................................................................................................... 2
2 Hardware Description ....................................................................................................... 3
3 Software ...................................................................................................................... 6
4 References ................................................................................................................... 7
Appendix A Amplifier Options.................................................................................................... 8
Appendix B Wired USB Demo With Back-Channel UART ................................................................. 10
Appendix C Wireless UART Demo With the eZ430 RF Target Board .................................................... 11
Appendix D Hardware Schematic Diagrams ................................................................................. 12

List of Figures

1 Human Heart Anatomy (left) and EKG Waveform (right)............................................................... 2
2 Hand Detection Circuit Diagram ........................................................................................... 3
3 Software Flowchart ......................................................................................................... 6
4 Heart-Rate Monitor Setup (left) and UART Output on PC (right)...................................................... 7
5 Hardware Schematic Diagram (Page 1 of 2) ........................................................................... 12
6 Hardware Schematic Diagram (Page 2 of 2) .......................................................................... 13

List of Tables

1 Pin Functionality Mapping – Left Header ................................................................................. 4
2 Pin Functionality Mapping – Right Header ............................................................................... 4

http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SLAA486B
http://www.ti.com/tool/MSP-EXP430G2
http://www.ti.com/tool/MSP-EXP430G2
http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/EKG-Based-Heart-Rate-Monitor/1_00_00_00/index_FDS.html
http://software-dl.ti.com/msp430/msp430_public_sw/mcu/msp430/EKG-Based-Heart-Rate-Monitor/1_00_00_00/index_FDS.html


P

Q

R

S

T

TIME

Differential Voltage
Between Two Electrodes

Atria
Depolarize

Ventricles
Repolarize

Ventricles
Depolarize

1 mV

Aorta

Left Atrium

Atrioventricular
Node

Left
Ventricle

Heart
Muscle

Sinoatrial
Node

Right Atrium

Right
Ventricle

Introduction www.ti.com

2 SLAA486B–January 2011–Revised June 2019
Submit Documentation Feedback

Copyright © 2011–2019, Texas Instruments Incorporated

EKG-Based Heart-Rate Monitor Implementation Using the MSP430G2xx
LaunchPad™ Development Kit

3 Supply Current Consumption .............................................................................................. 5
4 Instrumentation Amplifier Comparison .................................................................................... 8
5 Operational Amplifier Comparison......................................................................................... 9
6 eZ430 RF Target Boards.................................................................................................. 11

Trademarks
LaunchPad, SimpliciTI, Code Composer Studio are trademarks of Texas Instruments.
IAR Embedded Workbench is a trademark of IAR Systems AB.
All other trademarks are the property of their respective owners.

1 Introduction
The source of the human heart beat is an electrical pulse generated by a cluster of cells within the heart
called the sinoatrial (SA) node [1]. This pulse travels from the SA node through the surrounding cells of
the heart and then to the atrioventricular (AV) node. The AV node acts as a gate that allows the atria to
finish contraction before allowing the pulse to move on to the ventricles. Each atrium pumps blood to a
corresponding ventricle. The right atrium pumps blood to the right ventricle to provide blood to the lungs.
The left ventricle, sourced by the left atrium, is the chamber that pumps blood throughout the body.

Figure 1. Human Heart Anatomy (left) and EKG Waveform (right)

The electrocardiogram (ECG) or elektrokardiogramm (EKG) is a medical standard for testing the human
heart for defects and diseases [2]. Figure 1 shows the anatomy of the human heart and the waveform of
the EKG signal. The EKG waveform can be used for extrapolation of data such as the number of
heartbeats per minute (BPM) and the values can range from 30 to 200 BPM or 0.5 to 4 Hz.

The typical amplitude of the R wave component of the EKG signal is approximately 1 mV [3]. This peak is
located within a group of peaks known as the QRS complex and represents the electrical pulse flowing
through the ventricles. As this pulse travels through the blood stream, it can be detected at various points
on the body. The extremities and the chest have become the standard locations for placing electrodes for
acquiring the EKG signal. In this application, the subject’s finger tips act as the differential point of contact
with conductive pads to detect the EKG signal.

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SLAA486B
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2 Hardware Description
The hardware is a daughterboard design attachable to the 10-pin headers on the LaunchPad development
kit. The daughterboard contains the analog front-end components, battery connectors, and headers, while
the MSP430 MCU, the back-channel UART, and the eZ430 emulator circuit with the USB connector reside
on the LaunchPad kit itself [4]. The schematic diagram of the hardware is shown in Appendix D.

2.1 Hand Detection Circuit
A resistor divider scheme is implemented to detect contact of the subject’s finger tips with the conductive
pads. The premise of this scheme is that the resistance of the human body between the finger tips is in
the range of 100 kΩ to 300 kΩ, and the resistance placed between the conductive pads is significantly
greater than this range, as Figure 2 shows.

Figure 2. Hand Detection Circuit Diagram

When contact is made, the current flows through the path of least resistance (the human body) causing
the voltage at the left conductive pad to change. This voltage is sampled by an analog-to-digital converter
(ADC) channel and the digital conversion result is compared against a set of thresholds to determine
good, bad, or no contact. Power and ground are supplied from the microcontroller pins and can be
disconnected to minimize supply current consumption in sleep mode.

2.2 Analog Front End (AFE)
As mentioned previously, the amplitude of the EKG signal is approximately 1 mV peak-to-peak. The noise
signals picked up by the human body (such as the 50- to 60-Hz line frequency) pose a serious problem to
detecting the low-frequency low-magnitude EKG signal. An analog front end with a high gain with low
cutoff filter frequency is necessary to condition this signal for digital conversion and processing. Because
the common-mode signals from the conductive pads are the same, a differential amplifier simply cancels
out the common-mode and amplifies the input differential EKG signal. The INA332 instrumentation
amplifier is a low-cost differential amplifier used in this application and has a common-mode rejection ratio
(CMRR) specification of 73 dB up to 10 kHz, quiescent current of 490 μA, and shutdown current levels
less than 1 μA. It can operate to a minimum supply voltage of 2.7 V with a dedicated shutdown pin.
Additional instrumentation amplifier options relevant to this application are summarized in Heart-Rate and
EKG Monitor Using the MSP430FG439.

The INA332 is configured to a gain of 10 V/V with external 0.1% 10-kΩ resistors. The conductive pads are
connected to the inputs with 51-kΩ resistors in series to limit the current from the human body and also
act as a RC low-pass filter. The 5-MΩ pulldown resistors from the pads to common-mode voltage (VCM)
help keep the voltage identical on both inputs and also provide a DC bias point for circuit operation. The
VCM voltage is generated by a general-purpose op-amp in the voltage-follower (low output impedance)
configuration to 750 mV.

The TLV274 is a quad operational amplifier (op-amp) used in this application with supply currents of
550 μA/channel and minimum supply voltage of 2.7 V. With a CMRR of 58 dB, the op-amps are used to
implement a second-order Sallen-Key low-pass filter (LPF) with gain of each stage at 8.5 V/V. The overall
gain of the AFE is 10 X 8.5 X 8.5 = 722.5 V/V, and the cutoff frequency is 16 Hz. Additional general-
purpose op-amp options relevant to this application are also summarized in Heart-Rate and EKG Monitor
Using the MSP430FG439 .

The resulting amplified and conditioned EKG signal output from the LPF is fed to the ADC channel of the
MSP430 microcontroller for conversion and processing. The shutdown pin of the INA332 and the VCC pin
of the TLV274 are connected to one general-purpose input/output (GPIO) pin of the MSP430 to enable or
disable the AFE. The GPIO pin is set to a low state to minimize supply current consumption in sleep
mode. As a precautionary measure, the AFE has protection diodes (TPD2E001) on the conductive pads to
prevent human electrostatic discharge (ESD) from causing component failure.

http://www.ti.com
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2.3 Pin Functionality Mapping on the LaunchPad Kit
The LaunchPad development kit has a 20-pin PDIP socket that a 14-pin or a 20-pin MCU can be plugged
into. The MSP430G2452 MCU was used for this application and has 8KB of flash, 256 bytes of RAM, a
Timer_A3, and an 8-channel ADC10 [10]. The pin mapping on the LaunchPad kit is designed to match the
pinout of the MSP430G2xx family of devices.

Table 1 and Table 2 show the pin functionality mapping for the left and right header pins, respectively, on
the LanchPad kit.

(1) Not used in this application.

Table 1. Pin Functionality Mapping – Left Header

Port or Pin Name Signal Name Description
VCC VDD Power (VDD) for the MSP430

P1.0 (LED1) LED_RED Indicates bad contact
P1.1 (TXD) UART_TXD UART transmit (TX) line
P1.2 (RXD) UART_RXD UART receive (RX) line
P1.3 (S2) P1_3 (SW2) Push button switch

P1.4 EKG Input to the ADC to sample filtered and amplified EKG signal
P1.5 HAND_LEFT Input to the ADC to sample hand-detection circuit signal
P2.0 N/A (1) N/A (1)

P2.1 N/A (1) N/A (1)

P2.2 N/A (1) N/A (1)

(1) Not used in this application

Table 2. Pin Functionality Mapping – Right Header

Port or Pin Name Signal Name Description
GND GND Ground (GND) for the MSP430
XIN P2_6 VDD for hand detection circuit

XOUT SHUTDOWN Enable or disable the AFE
TEST TEST Spy-Bi-Wire programming pin for the MSP430

(S1) RST RESET (SW1) Reset switch for the MSP430 (Spy-Bi-Wire programming pin)
P1.7 P1_7 GND for hand detection circuit

(LED2) P1.6 LED_GREEN Indicates good contact
P2.5 N/A (1) N/A (1)

P2.4 N/A (1) N/A (1)

P2.3 N/A (1) N/A (1)

2.4 eZ430 RF Target Header
The hardware has a six-pin header that has power/ground connections and UART lines coming from the
LaunchPad kit. This header allows for an eZ430 RF target such as the eZ430-RF2500 to be connected for
wireless data transmission [5]. Appendix C has details on target boards with different frequencies and the
SimpliciTI wireless UART demo software for programming them that are provided with this application
report.

2.5 Power Supply Setup
With the daughterboard attached to the LaunchPad kit, there are multiple ways of powering up the system.

NOTE: The system is designed to be powered from only one power source at a time. The system
should be powered from either USB or coin-cell or 2x AA or 2x AAA batteries.

http://www.ti.com
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USB Power
1. Populate all of the jumpers on the LaunchPad kit (VCC, RXD, TXD, TEST, RST).
2. Remove the jumper JP1 on the daughterboard.
3. Connect the micro-USB cable from the LaunchPad kit to the PC. The 5 V from USB supply goes

through a 3.3 V LDO and powers the whole system. The USB cable also serves as an application
UART connection between the PC and the LaunchPad kit [4].

WARNING
When powering the system from USB, disconnect all batteries
(coin-cell or 2x AA/AAA) connected to the system. If any battery
remains plugged in, there is a risk of the battery being charged that
could lead to an explosion, which causes potential for property
damage, personal injury or death.

External Battery Power
1. Remove all LaunchPad kit jumpers (VCC, RXD, TXD, TEST, RST).
2. Populate the jumper JP1 on the daughterboard.
3. Plug in the battery to connector B1 to power the system from one 3-V CR2032 coin-cell battery or plug

in the connector to header B2 to power the system from two AA or AAA batteries.

WARNING
When powering the system from batteries, either the coin-cell or
the 2 AA or AAA batteries connector should be plugged in. If both
are connected together, there is a risk of one battery charging
other that could lead to an explosion, which causes potential for
property damage, personal injury, or death.

Table 3 shows the supply current consumption of the system in different power modes.

(1) System is in low-power mode 3 (LPM3).

Table 3. Supply Current Consumption

System State Supply Current (Typical)
Active mode (without eZ430 RF target) 2.1 mA
Active mode (with eZ430 RF target attached) 2.5 mA
Sleep mode (with eZ430 RF target attached) (1) 2 μA

http://www.ti.com
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3 Software
Figure 3 shows the flow chart for this application software.

Figure 3. Software Flowchart

It begins by initializing the MSP430 in LPM3 sleep mode, configuring the watchdog timer in interval-timer
mode (sourced by ACLK or VLO), and disabling the AFE. When the interval (approximately 1 second)
expires, the ADC is triggered for single-channel single conversion. With the hand-detection circuit enabled,
the left pad is sampled by the ADC and compared against a set of thresholds to determine the quality of
contact. If the voltage on the left pad exceeds 1.7 V, the contact is considered good, and the green LED
on the LaunchPad kit flashes briefly. If the voltage exceeds 1.5 V, the contact is considered bad and the
red LED flashes briefly. The default value on the pad for no contact is 0.825 V (with 3.3-V supply voltage).

If there is no contact, the MSP430 MCU enters LPM3 sleep mode until the interval expires again. If there
is contact (good or bad), the hand-detection circuit is disabled, the AFE is enabled, the watchdog interval
timer is sourced from MCLK/DCO, and the sleep mode changed to LPM0. The DCO runs with a calibrated
value of 1 MHz, and the interval timer runs at 60 Hz. Therefore, the ADC is triggered to sample the
amplified and filtered EKG signal at the output of the AFE every 16 milliseconds. The digital conversion
values are stored in memory and are used by the heart rate detection algorithm to compute the number of
heartbeats per minute [9].

http://www.ti.com
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The heart rate value is transmitted using a Timer_A based UART. The UART output can be relayed to the
PC by means of either the back-channel UART-over-USB connection on the LaunchPad kit or the eZ430
RF target header on the daughterboard. During the EKG sampling by the ADC, the hand-detection circuit
is momentarily enabled every 3 seconds to ensure that contact is being made. If there is contact, the
application returns to EKG sampling. If not, the hand-detection circuit remains enabled, and the
applications checks for contact for approximately 10 seconds. If there is still no contact, the AFE is
disabled and the MSP430 MCU returns back to the initial LPM3 state in which it checks for contact every
second.

Details on programming the software on the heart-rate monitor setup are provided in Appendix B and the
eZ430 RF target boards in Appendix C. Figure 4 shows the complete hardware in action (left side) and the
UART output log display on the HyperTerminal application window on the PC (right side).

Figure 4. Heart-Rate Monitor Setup (left) and UART Output on PC (right)

4 References
1. http://www.daviddarling.info/images/sinoatrial_node.jpg
2. http://www.medterms.com
3. Heart-Rate and EKG Monitor Using the MSP430FG439
4. MSP-EXP430G2 LaunchPad Development Kit User's Guide
5. eZ430-RF2500 Development Tool User’s Guide
6. A2500R24A-EZ4x - Integrated Radio (AIR) EZ4x Module Series Product Brief: Anaren

(http://www.anaren.com)
7. AMB8423-EM – 868 MHz Radio Module for TI Development Tool eZ430-RF2500 Datasheet: Amber

Wireless (http://www.amber-wireless.de/index.php)
8. Wireless Sensor Monitor Using the eZ430-RF2500
9. Sourabh Ravindran, Steven Dunbar, and Bhargavi Nisarga, Real-Time, Low-Complexity, Low Memory

Solution to ECG-Based Heart Rate Detection, IEEE Engineering in Medicine and Biology Society
(EMBC), 2009.

10. MSP430G2x52, MSP430Gx12 Mixed-Signal Microcontrollers data sheet

http://www.ti.com
http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SLAA486B
http://www.daviddarling.info/images/sinoatrial_node.jpg
http://www.medterms.com
http://www.ti.com/lit/pdf/SLAA280
http://www.ti.com/lit/pdf/SLAU318
http://www.ti.com/lit/pdf/SLAU227
http://www.anaren.com
http://www.amber-wireless.de/index.php
http://www.ti.com/lit/pdf/SLAA378
http://www.ti.com/lit/pdf/SLAS722


A1

–

+

A3

–+

–

A2

+

–

RFI Filtered Inputs

RFI Filtered Inputs

RFI Filtered Inputs

RFI Filtered Inputs
INA333

RG

VIN–

VIN+

2

1

8

3

V–

4

V+

7

6
VOUT

5
REF

50kΩ

50kΩ

150kΩ

150kΩ

150kΩ

150kΩ

G = 1 +
100kΩ

RG

REF

VIN–

160kΩ

VIN+

40kΩ

A1

–

+

40kΩ 160kΩ

R1 RG R2

VOUT

A2

–

+

A3

–

+

Gain = 5 + 5(R2/R1)

V = (V – V ) • GainOUT IN+ IN–

V+ V–Shutdown

A1

–

+ A2

–

+

A3

–

+

R1
R2

RG

VREF

40kΩ 10kΩ

10kΩ

V +IN

V –IN

V+ V– Shutdown

VOUT

INA332

G = 5 + 5(R /R )2 1

40kΩ

8 SLAA486B–January 2011–Revised June 2019
Submit Documentation Feedback

Copyright © 2011–2019, Texas Instruments Incorporated

EKG-Based Heart-Rate Monitor Implementation Using the MSP430G2xx
LaunchPad™ Development Kit

Appendix A
SLAA486B–January 2011–Revised June 2019

Amplifier Options

A.1 Instrumentation Amplifier Options
This reference design uses the INA332 as the instrumentation amplifier for the analog front end. Table 4
shows other options for the instrumentation amplifier.

Table 4. Instrumentation Amplifier Comparison

Device Name INA321 INA332 INA333

Quiescent current 40 µA/channel 490 μA/channel 50 μA/channel
Shutdown current <1 μA approximately 0.01 μA No shutdown
Bandwidth 500 kHz, G = 5 V/V 2 MHz, G = 25 35 kHz, G = 10
Slew rate 500 kHz, G = 5 V/V 5 V/μs for G = 25 0.16 V/μs for G = 1
Supply voltage 2.7 V to 5.5 V 2.7 V to 5.5 V 1.8 V to 5.5 V
Price/1ku
(listed on
http://www.ti.com)

1.25 0.55 1.80

The INA321 is pin-to-pin compatible with the INA332 and uses a two-resistor feedback network to set the
gain. It also offers significantly lower quiescent current, although it costs more. The INA333 has a different
architecture in which the gain is set by one resistor. While it lacks a shutdown pin, the quiescent current
consumption levels are comparable to the INA321 with the advantage of operating as low as 1.8 V. While
the most expensive of the three, the INA333 is ideal for battery-operated portable systems with low-
voltage operating range.

http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SLAA486B
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A.2 Operational Amplifier Options
This reference design uses the TLV274 as the op-amp for the Sallen-Key low-pass filter implementation.
Table 5 shows other options for the operational amplifier.

Table 5. Operational Amplifier Comparison

Device Name TLV274 TLV2375 TLV2765 TLV2765

Supply current 470 μA/channel
(VDD = 2.7 V)

470 μA/channel
(VDD = 2.7 V) 20 μA/channel 650 μA/channel

Shutdown current No shutdown approximately 25 μA approximately 10 nA 900 nA

UGBW 2.4 MHz
(VDD = 2.7 V)

2.4 MHz
(VDD = 2.7 V) 500 kHz 8 MHz

Slew rate 2.1 V/μs
(VDD = 2.7V) 2 V/μs (VDD = 2.7 V) 0.2 V/μs

(VDD = 2.4 V)
4.8 V/μs

(VDD = 2.7 V)
Supply voltage 2.7 V to 16 V 2.7 V to 16 V 1.8 V to 3.6 V 1.8 V to 3.6 V
Price/1ku
(listed on
http://www.ti.com)

0.46 0.85 1.50 1.60

The TLV2375 has specifications similar to the TLV274 with the additional capability of shutdown pins. The
TLV2765 and TLV2785 can operate in low-voltage range with sub-microamperes of current consumption
in shutdown mode.

http://www.ti.com
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Appendix B
SLAA486B–January 2011–Revised June 2019

Wired USB Demo With Back-Channel UART

The default setup for the heart-rate monitor uses the onboard emulator circuit on the LaunchPad kit to
send data from the MSP430G2xx MCU UART through the USB to the PC. Virtual COM port drivers should
be installed on the PC so that the USB connection appears as the MSP430 application UART. These
drivers should be on the system by default when either IAR Embedded Workbench or Code Composer
Studio IDE are installed. If a system is devoid of any MSP430 development tools, the drivers can be
installed by referring to the executable file in reference link [8].

To setup the system with USB:
1. Populate all of the jumpers on the LaunchPad kit (VCC, RXD, TXD, TEST, RST).
2. Remove the jumper JP1 on the daughterboard.
3. Attach the daughterboard to the LaunchPad kit.
4. Connect the mini-USB cable from the LaunchPad kit to the PC.

The zip file associated with this application report has two folders that contain source code and project
files for IAR Embedded Workbench™ IDE v5.10 and Code Composer Studio™ IDE v4.2.1.

To download the source code in IAR Embedded Workbench, see the folder: Software/Heart Rate
Monitor/IAR.
1. Open the Project: File → Open Workspace and select HRM.eww. If needed, select Project → Add

Existing Project and select HRM.ewp.
2. Compile the project: Project → Make.
3. Download the code: Project → Download and Debug.
4. Run the code: Debug → Go.

To download the source code in Code Composer Studio, see the folder: Software/Heart Rate
Monitor/CCS.
1. Import the Project: Project → Import Existing CCS/CCE Eclipse Project and select the Code Composer

Studio folder as the search directory. Select HRM to import the project and source code.
2. Compile the project: Project → Rebuild All.
3. Download the code: Target → Debug Active Project.
4. Run the code: Target → Run.

The UART output from the MCU can be viewed on the PC with HyperTerminal.
1. Go to Start Menu → Accessories → Communications → HyperTerminal.
2. Enter a name for the connection and select the virtual COM port for the MSP430 Application UART

applicable to the LaunchPad development kit. To find the appropriate COM port number, open up
Device Manager → Ports (COM & LPT) and select the COM port titled MSP430 Application UART.

3. Change the bits per second to 9600 baud and click OK. If necessary, select Call → Call.

http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SLAA486B
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Wireless UART Demo With the eZ430 RF Target Board

The heart-rate monitor hardware has a six-pin eZ430 connector to which an RF target board can be
connected, allowing heart-rate data to be transmitted wirelessly to another RF target board connected to a
PC (access point). This configuration serves as an alternative to the back-channel UART-over-USB cable
and can be used with a 3-V CR2032 coin cell battery or two AA or AAA batteries.

An example of the RF target board is the eZ430-RF2500 Development Tool Kit from Texas Instruments,
which comes with an eZ430 emulator for programming and debugging the RF target board. The RF target
contains the MSP430F2274 microcontroller linked to the transceiver chip, CC2500, for 2.4-GHz operation.
The MSP430F2274 is programmed with the Spy-Bi-Wire (2-wire JTAG) protocol. For more details on the
hardware specifications, see the eZ430-RF2500 Development Tool User’s Guide.

RF target boards with the same form factor and pinout, but different frequency ranges, are available from
vendors such as Anaren [6] and Amber Wireless [7]. Table 6 shows the options.

Table 6. eZ430 RF Target Boards

Manufacturer Part Number Transceiver Chip Frequency
Texas Instruments eZ430-RF2500 CC2500 2.4 GHz
Anaren A2500R24A-EZ4 CC2500 2.4 GHz
Anaren A1101R09A-EZ4 CC1101 900 MHz
Amber Wireless AMB8423 CC1101 868 MHz

The software for programming the RF target boards and demonstrating wireless capability is provided in
the zip file available for download along with this application report. The source code is written in C and
project files are provided for both IAR Embedded Workbench IDE v5.10 and Code Composer Studio IDE
v4.2.1. The software is based on the wireless sensor demo using the eZ430-RF2500 and uses the two RF
target boards supplied with the tool kit [8].

NOTE: If using the IAR Embedded Workbench Full Version, the existing project settings will not
work properly. Go to Project Options → Linker → Extra Options and uncheck the Use
command line options -- ks_version. This extra option is required to overcome the 4KB code
size limitation of the Kickstart version only.

One RF target board serves as the end point and the other serves as the access point. The end-point
target board (connected to the hardware through the 6-pin connector, as previously mentioned) receives
data through UART (9600 baud) and transmits it using the SimpliciTI protocol to the access point. When
not receiving bytes from the UART, the RF target turns off the antenna/transceiver and goes into LPM3 to
prevent battery drain. The access point target board (connected to the eZ430 emulator plugged into the
USB port of a PC) receives data using the SimpliciTI protocol from the end point. It then outputs that data
through the backchannel UART-over-USB, and the data can be displayed on a HyperTerminal on the PC
at the rate of 9600 baud (see Appendix B).

To compile the source code files for the RF target boards with either CC2500 or CC1101, two project files
have been provided with predefined settings and are named to reflect the transceiver being used. Details
on compiling the project, function call descriptions, and setting up the UART and HyperTerminal can be
found in the reference documents [4] and [7]. The zip files associated with these application reports
contain the COM port drivers essential for the eZ430 emulator to function as the MSP430 application
UART.
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Hardware Schematic Diagrams

Figure 5. Hardware Schematic Diagram (Page 1 of 2)
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Figure 6. Hardware Schematic Diagram (Page 2 of 2)
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